tor-browser-windows-x86_64-portable-15.0.6.exe /Stor-shopping-list.txt and put a few fake (illicit) items in there.| Name | DeviceFileEvents |
|---|---|
| Info | Microsoft Defender Reference |
| Purpose | Used for detecting TOR download and installation, as well as the shopping list creation and deletion. |
| Name | DeviceProcessEvents |
|---|---|
| Info | Microsoft Defender Reference |
| Purpose | Used to detect the silent installation of TOR as well as the TOR browser and service launching. |
| Name | DeviceNetworkEvents |
|---|---|
| Info | Microsoft Defender Reference |
| Purpose | Used to detect TOR network activity, specifically tor.exe and firefox.exe making connections over ports to be used by TOR (9001, 9030, 9040, 9050, 9051, 9150). |
The following Kusto Query Language (KQL) scripts were utilized to hunt for the Indicators of Compromise (IoCs) generated during the event.
// Installer name == tor-browser-windows-x86_64-portable-(version).exe
DeviceFileEvents
| where FileName startswith "tor"
// Take note of two spaces before the /S
DeviceProcessEvents
| where ProcessCommandLine contains "tor-browser-windows-x86_64-portable-15.0.6.exe /S"
| project Timestamp, DeviceName, ActionType, FileName, ProcessCommandLine
DeviceFileEvents
| where FileName has_any ("tor.exe", "firefox.exe")
| project Timestamp, DeviceName, RequestAccountName, ActionType, InitiatingProcessCommandLine
DeviceProcessEvents
| where ProcessCommandLine has_any("tor.exe","firefox.exe")
| project Timestamp, DeviceName, AccountName, ActionType, ProcessCommandLine
// TOR Browser or service is being used and is actively creating network connections
DeviceNetworkEvents
| where InitiatingProcessFileName in~ ("tor.exe", "firefox.exe")
| where RemotePort in (9001, 9030, 9040, 9050, 9051, 9150)
| project Timestamp, DeviceName, InitiatingProcessAccountName, InitiatingProcessFileName, RemoteIP, RemotePort, RemoteUrl
| order by Timestamp desc
// User shopping list was created, changed, or deleted
DeviceFileEvents
| where FileName contains "shopping list.txt"
| Version | Changes | Date | Modified By |
|---|---|---|---|
| 1.0 | Initial draft | 2026-02-16 | Steven Bealle |